ACO5426E The SQL log on does not have the Sysadmin role

Problem(Abstract)

A Data Protection for Microsoft SQL backup run manually and completes sucessfully. When the backup is run with the client scheduler, the backup fails with the ACO5426E error.

Symptom

The following error is logged in the Data Protection for Microsoft SQL log file :

ACO5426E The SQL log on does not have the Sysadmin role: CSqlApi::LogonServer:6638:1904 Server:IsSysadmin:false
The QUERY EVENT Tivoli Storage Manager administrative command shows the schedule as Failed with return code 1904. For example : Q EV * * F=D Policy Domain Name: SQLDOMAIN Schedule Name: SQL_FULL Node Name: MY_SQL Scheduled Start: MM/DD/YYYY HH:MM:SS Actual Start: MM/DD/YYYY HH:MM:SS Completed: MM/DD/YYYY HH:MM:SS Status: Failed Result: 1,904 Reason: Failed


Cause

Windows account running the scheduler service does not have the sysadmin role on the SQL server.

Diagnosing the problem

Review the “C:\Program files\Tivoli\TSM\tdpsql\tdpsql.cfg” file. Verify what value is specified for the SQLAUTHentication option. In this case, the option was not configured and the following default value was used : [SQLAUTHentication INTegrated

Review the Tivoli Storage Manager client scheduler in Windows and verify which account is used to run the service. In this case, the scheduler service was configured to run with the “Local System Account”.

Resolving the problem

When using the INTegrated option, it means that the userid doing the backup (or the account running the Data Protection for Microsoft SQL scheduler service) must have the sysadmin role on the SQL server. When the scheduler service is run with the “Local System Account”, you need to “NT AUTHORITY\SYSTEM” to the sysadmin role on the SQL server otherwise run the scheduler service with a different Windows account which has sysadmin role to the SQL server.

source: http://www-01.ibm.com/support/docview.wss?uid=swg21691523